Spencer Review - Dec 2020

Hello everyone, greetings from Greece.

So today I received my Spencer and decided right on to get onto it. Even though I have zero prior experience with soldering, in a just a couple hours Spencer was ready for Circuitblocks. Great packaging, solid instructions, generally an interesting experience, recommended for any age. (Im 26)

A few notes

  1. Soldering pen - [I have the one with the blue light and manual button] I initially connected it to my laptop (through a USB hub) but while soldering I would notice, probably because the iron was not heated enough, that a small quantity of soldering tended to accumulate on the needle, thus making the iron unusable - I had to regularly use a knife to clean the needle of the soldering. At the end I used a 40W iron I had from my Father’s lab and everything went smoothy from that point. Maybe if I had connected it directly to a power supply it would be enough.

  2. Big red button - If you turn or flip Spencer, the button will fall off. A workaround I found was using a little bit of superglue with a stick and now its solid.

  3. Circuitblocks App - [Installed on a Mac OS Catalina 10.15.7] Installation was stuck while on Arduino installation, forced closed the app and it ended up finishing smoothy.

Spencer is not available yet in the projects, so I just changed the settings on the top right corner. Added the SSID and the password, but unfortunately Spencer hasn’t connected and neither does anything when I press the red button.

The light panel is working normally, though the red light is inoperative when I press the red button.

Any solution on how to make Spencer work?

Also, what does the small button do on the back? Is it like a forced restart or reset?

Thanks,

Paul

Update: Spencer lights after 10 minutes of use stuck in a shape, decided to remove the power cable and re-insert and now it doesn’t start at all…

Update 2.0 - Spencer is still DEAD.

I resolded the Capacitors, checked and then did the same with every other soldable object but to no avail. I will bring a polymeter by next week along with a friend who is a Techie to see what happened.

Maybe the system short circuited as soon as I took off the power cable to reset it?

Update No3 - I fixed the problem by connecting Spencer to the USB and click restore firmware… and spencer was alive again. Interesting to see that this was a firmware malfunction after I had entered my Wifi details. Red light works as well.

Now the original problem still stands though - spencer is active, have inserted the WiFi details but neither pressing the button does anything neither there is no response from Circuitblocks for connecting spencer to WiFi.

Any thoughts?

Hey, can you please reach out to [email protected] and someone from the team will help. Please send photos of your build.

Thank you

Hello Albert I have a similar problem with Mac Mojave, I send image and a video to [email protected]. The problem is CircuitBlocks app please help me

1 Like

Hello,
I have/had pretty similar issues:

  • I found that the temp. of the soldering iron wasn’t hot enough to properly solder.
  • The big red button isn’t fix at all.
  • I couldn’t get the 64bit Circuitblocks app running (on Win 10), needed to switch to 32 bit.
  • and most importantly: Spencer stopped to react on button presses:
    When I finished the assembly and got the 32bit app running, I could successfully connect to the WiFi and interact with Spencer. Button press --> command --> answer, all worked (although with a lot of lag, sometimes it took him 3-5sec to respond). However, when I turned him off and later on again, he complained that he couldn’t connect to the WiFi (possibly because I went to another room farther away from the router). So I opened CIrcuitblocks again and entered details of another WiFi with stronger signal there but he didn’t connect. Ever since, pressing the red button doesn’t do anything.
    I tried to power him on/off a couple of times, switches back to the old spot & WiFi, restored the firmware, pressed the reset button, nothing works. The LEDs are on and showing all kinds of patterns, I hear his voice when I turn him on but nothing happens when the red button is pressed. I also can no longer change his settings in Circuitblocks, only when I restore the firmware.

Please let me know what I can do to “reanimate” him?

Hi, please reach out to [email protected] and we’ll help. Thank you

Hi. Same issues with the soldering pen here. It gets cold, even when connected to a power supply and not a laptop. Is it a defective one?

Hi, please reach out to [email protected] and we’ll help. Include a video.

Thank you

Hi,
I finally got some time to put spencer together, I was going to make it a family thing but I could not see my 12 year old doing this for his first soldering project with what was included.

Here is my 2 cents:

  1. Great idea
  2. Soldering gun is junk, it would not get the pads on the board hot enough to accept solder. Finally after a half hour trying, I went and got my Weller. Since then everything was much better.
  3. Because of number 3, I would have move a couple of the items on the board further away from the ic’s and traces. When I was trying with the included pen, I thought I was going to damage the board by continuously trying.
  4. Spencer is extremely slow, now I see why the RGB leds were abandoned.
  5. After Spencer is on for a little bit, he becomes unresponsive.(I think restoring the firmware helped with this.)
  6. Button doesn’t stay on.
  7. For the time he has been out. I would have thought there would be more sample code on your site.
  8. I think you did a very good job on the acrylic. It is much better then other projects I have done.

Maybe my expectation was too great, but what I thought would have been a learning experience for my kids will just be an object on my desk that will get dusty over time. I am trying to justify the cost with the final product.

I am only posting, because I would really love to see the next one hit it out of the park.

Thanks
Bo

Thank you for your feedback.

If your soldering iron is not working properly, please reach out to us via [email protected] and we’ll send you a new one.

Spencer should not become unresponsiveness after some time, please reach out to our support team with more information on that.

The sample code we have so far can be found here:
https://circuitmess.com/resources/guides/en/spencer-coding-1

Thank you for supporting our work