Step 12 ->it doesn't work [SOLVED]

I checked my soldering twice but found no error.
Is there a easy way to check whether I got an ATmega328 without firmware (I’m a newbie and have no arduino board or AVR progammer).

@Nischwan, thank you for supporting our project.

I am sorry that you’re having problems with your build.
As reported on the forum, there are a few kits that were sent with blank ATmegas due to our manufacturing error (about 30 kits to be more exact).
We will send you a new microcontroller ASAP if you’re among those 30 unlucky ones.

Your soldering looks damn fine (well done man, you don’t seem like a newbie to me).
Do this:

  1. check whether the 3.3V regulator and the 2N2222 transistor are in the right places.
    (Step 8, chapter 3 in the build guide):
  2. A) -solder the 6 pin female header (step 14, chapter 4)
    -connect the MAKERbuino to your computer using the USB-TLL board
    -install Arduino IDE
    -select the right COM port and “Arduino UNO” as the board you’re using
    -try uploading a simple blink program to your MAKERbuino
    -if the upload succeeds, there is a bootloader in your microcontroller (it’s not blank), if it fails - your microcontroller is blank
    -this video might help you: (note that they’re using Arduino Pro mini boards in the video and the MAKERbuino is programmed as an Arduino UNO board)
    B) If you cannot figure step 2A and don’t know what I’m talking about, we’ll just send you a new mirocontroller

Don’t give up!

1 Like

I don’t have anything relevant to add but I’ve got to agree with @albertgajsak, for a newbie you’ve done some of the neatest soldering I’ve seen on these forums.


First thx a lot for your fast and helpful responses.

  1. I’ve checked the regulator / transistor more than twice.

  2. I installed the ardino IDE

than tried to select the correct COM-Port and Arduino UNO:


I don’t know if the (pre)-selected progammer is correct ?

But the upload wont work

Is there another way to fix it ?
There is a menu called “bootloader brennen” -> is this a way to programm it on my own ?

Thx by the way that my soldering seems to look not too ugly :wink:

1 Like

@Nischwan, this looks like a case of a blank microcontroller.
If you’ve checked your wiring with the serial port, which should look like this:
FTDI ----------------- MAKERbuino

Your microcontroller is blank. I apologize for that, we are the ones to blame for this.
Yes, there is a “burn bootloader” button but you cannot burn the bootloader with a USB-TTL adapter, you’ll either need another Arduino board or an ICSP programmer (USBasp for example).
You can read more about that here:

If you do not have an extra Arduino board (as you said in your first post) or an ICSP programmer, we will send you a new microcontroller ASAP.
Please send me your order ID and address via private messages and I will arrange the shipment.

Sorry again

1 Like

thx for the quick response.
unfortunaly I do not have am extra Arduino board.

My Order numer was #844.

so I will be waiting for the shipment :wink:

1 Like

I decided to buy an arduino board and after some hours and the help from many tutorial ( and with a lot new things to learn) I suceeded in burning a bootloader on my empty chip.
In the end I used the commandline avrdude with the -F option because of wrong/missing signature.

So today I finished soldering and everything looks good.

Thx for all the support !

1 Like

@Nischwan, I am sorry for my late reply, we were out of office for a couple of days due to a foreign maker faire we were attending. I’ve just replied to your PM.
I’ve planned to send you the microcontroller tomorrow, but I think you won’t need it now since you’ve managed to burn the bootloader yourself.

Kudos, burning a bootloader is not an easy task, you’ve just earned a couple of badges :slight_smile:
I will also mark this topic as solved

P.S. @Nischwan, show us your MAKERbuino! (pics or it didn’t happen :wink: )

I posted a picture in the introductuion area :rofl:

1 Like