Stuck Booting

Built the ringo and all WAS working for all of 1 day. Then it got stuck in a “Loading” loop. Screen shows “Circuit Mess - Ringo - Loading” for several 10 to 15 seconds then blanks and goes back to the Loading screen.

I have checked all soldered joints from the mother board to the “Brain” and also on the display and sound board but cannot see an issue.

I have reset it, powered it off, restarted, removed the battery, checked all soldered joints and re-assembled, but still stuck in the booting screen.

Where do I go from here?

Have you tried reloading the firmware from CircuitBlocks or the Arduino IDE?

1 Like


Yes, just like @kfixman said, please try to reload the default firmware. You can do it either by Arduino IDE or our own IDE called CircuitBlocks.

Did you maybe upload something in the meantime to the flash memory so that the phone is not loading the default firmware?


It sounds like firmware.

I don’t know if you’re familiar with debian? It may alternatively be a problem similar to GUI formatting. Look up pocket-home for CHIP and you can find a lot of messages that talk about how you should be careful with the config.json file.
Then reference that in comparison to loading the homescreen in the Ringo firmware.

Although, flashing the firmware should work .

I have tried to reload the firmware using CircuitBlocks. It never gets beyond 0% and then I simply get “Error. Upload error. Check your ring then try again.” I press “OK” and then try again and get the same response. Whilst trying to Reload Firmware the ring keeps going through the same Booting sequence (i.e. loading… then screen goes blank then back to Loading…)

Also, when I try and install CircuitBlocks on Mac OSX 10.15.3 the installation simply hangs - it never gets beyond “Installing … Arduino … Hold on tight … This might take up to 10 minutes.” It’s been on that screen for the last 30 minutes.

1 Like

I did not upload anything to the ringo. It was working for several hours and then it got stuck in the booting sequence. As you can see from my further post, I have tried to reload the firmware but can’t seem to get to communicate with the ringo at all.

1 Like

For what it is worth, I had to try different usb ports on the computer before I got one to work.

1 Like

That indicates a driver issue. Without installing the proper software, try to check the bus and driver. On Windows it is called “Device Manager”.

-It is possible to have conflicting COM ports. Manage your dev/tty

Check the Arduino IDE before installing new Arduino drivers. It is tedious, but it’s a microcontroller… It is self-evident.

-Ensure the correct port is read with the connected device.

These steps are equal with CircuitBlocks. Whether in-browser or a window, there is a driver for the software to read the /tty bus-SPI port. A Mac is UNIX so it is much easier to manually install SPI drivers.

The second requirement is the Ringo programmer. That is the driver the /tty uses to flash the peripheral. Without that, you may as well install random Adafruit libraries. The programmer determines the device.

Hopefully, some of this information is useful.
I have years of problems and experience with Arduino.
It’s very difficult at first…don’t give it up.


There are several topics on this forum where people have had issues with connecting to some of the Macs. Macs are usually known to have a lot of issues with their ports, as stated on their official website, so trying multiple ports and playing with the drivers seems to be the solution for most of these issues.

If you don’t manage to fix that, I would recommend connecting to the normal computer and trying to restore the firmware via either CircuitBlocks or Arduino IDE. It is important that you upload that firmware, so that we know if you maybe have some hardware issues or not.
I’m happy to help in any way I can, but this Mac port problem is completely out of my reach.

Stay in touch, we’ll sort it out!

1 Like


My “normal” computer is a Mac.

I did re-install Circuit Blocks without any errors on the Mac.

I can see the ringo from the Mac reported on the USB subsystem. It is reported as cP2104 USB to UART Bridge Controller, But every time I try and “Reload Firmware” I simply get an error.

If I run a windows 10 virtual machine (I don’t have a PC), I can again see the USB device, but Circuit Blocks gives the same error (although it does take longer to give the error and still gets no further than 0%).

If I run the Arduino app I can see the device listed, but when I try to read the device Board information I don’t get any information. When I plug in an Arduino Uno I do get the information from the board. However, I do not see a port relating to the ringo. I do see /dev/cu.Bluetooth-Incoming-Port which is reported as:

crw-rw-rw- 1 root wheel 18, 1 18 Feb 18:18 cu.Bluetooth-Incoming-Port

but I don’t think that is related to the ringo. I do not see another possible device created when the ringo is plugged in.

I believe that the ringo is reported in the System report as:

CP2104 USB to UART Bridge Controller:

Product ID: 0xea60
Vendor ID: 0x10c4 (Silicon Laboratories, Inc.)
Version: 1.00
Serial Number: 01845F73
Speed: Up to 12 Mb/s
Manufacturer: Silicon Labs
Location ID: 0x14214000 / 16
Current Available (mA): 500
Current Required (mA): 100
Extra Operating Current (mA): 0

So, I’m stuck at the moment.

BTW, for a couple of hours the ringo decided to work and completed the boot. But then it reverted to the booting loop.


1 Like

I have the same problem with my i2c on Vortex. You can click on my profile for the link, it’s the exact same issue on the software level.

At least we’re on to something…
Did you try anything different from the last post to trigger the clean boot?

On my Vortex it started working over USB which at first I thought the problem was power related, but then it started acting up at random times on the floor. I don’t know if it’s a comparable test.

Okay, this seems to be something completely new.

Since it did work for a while, I would imagine that the software is okay there.

There could be a couple of fixes - sometimes, Ringo’s upload doesn’t work unless you press the reset button (little button on the side of the ESP32) at the exact moment of the upload. It seems like some of the boards, a very little number of them, have that error.

But about the whole booting process - there is a possibility that one of the soldering joints is not properly soldered or that there is a bit of soldering left somewhere on the board which is causing the whole board to reset once it boots. Also, auto-reset can occur when memory overflow happens, which it would be weird right now.

I would suggest to check soldering joints and try to clear the whole board if there are any solder leftovers. Also, try the reset button trick when uploading.

If none of these things work, the best thing would be to send the phone to us so we can check the components and replace them if necessary. Sorry for the issues but we’ll get everything working! :smiley:


1 Like


I have checked all the soldered joints (re-soldered, checked for bridges etc.) and checked for any solder left on the board anywhere.

How do I arrange to send it back to you?


1 Like


Have you seen my DM?
I’ve sent you the information a week ago so please check it so we can fix this. :slight_smile: