Trouble with CircuitBlocks

Hello, I’m trying to get circuitblocks running on my Mac (Big Sur) so I can update my Wheelson firmware. I’ve installed the application and associated Arduino app as well. However, I get this Library Update error:
Screen Shot 2021-12-21 at 7.53.54 AM
Screen Shot 2021-12-21 at 7.59.14 AM

Most assuredly my internet connection is functioning.

I noticed that I was not able to launch the Arduino application that Circuit Blocks installed. I tried installing the Arduino IDE from, but that had no effect on the CircuitBlocks error, even after reinstalling circuitblocks.

Any ideas?

Thanks in advance.

Oh, and just to add when getting into the circuitblocks app without the library update, the firmware updaters don’t work either.

Hello there!

CircuitBlocks relies on installing the Arduino IDE and our Arduino platform containing code, libraries, and firmware for all our devices. If that step fails, compiling and restoring firmware wont work.

If CircuitBlocks fails to install the platform for any reason, you can do it manually by following the manual installation steps outlined here: GitHub - CircuitMess/Arduino-Packages: Contains platforms and board definitions for CircuitMess' devices. . For Wheelson use the ESP32 platform index.

After you install the platform through Arduino IDE, CircuitBlocks will detect it and you’ll be able to compile sketches and restore firmware.

If you still have errors after that, please contact us at


Hi Filip, that worked, thank you. Circuitblocks will now open and update properly.

At this point, I get an Upload error when I try to restore the Wheelson Firmware. However, when I open a test sketch in Circuitblocks, the window says “Wheelson Connected”. I’m using a legit USB-C cable that came with ByteBoi.

I’m trying to get Wheelson updated so it can be controlled by ByteBoi.

Any ideas at this point?


Screen Shot 2021-12-22 at 10.31.49 AM
Screen Shot 2021-12-22 at 10.32.27 AM

Hello again!

Unfortunately, without an error report it’s difficult to debug an error like this. I’m pushing an update tomorrow which will fix sending error reports and let you know when it’s out. I’ll be able to provide further help after that.


1 Like

I ran into the “Restoring firmware” issue with my Windows 10 machine. I initially downloaded the 64 bit version and could not restore firmware. I tried the 32 bit version and was successful.

Hello! I too am having the same problem after installing the ESP32 platform index with regards to updating the firmware. I am also having difficulties with what I can only assume is a software issue… Originally when I booted up Wheelson and did the initial hardware diagnostics, I got all the way through them except for the fact that the front left wheel did not turn.

Through further testing we found that when going forwards, all the wheels except the FRONT left wheel turn and when going backwards, all the wheels except the REAR left wheel turn.

Now whenever I try to run the hardware diagnostics, the system crashes and reboots on the LED test.

Help please and thank you!


Hey guys! The update is pushed so you can send an error report now. If you have any issues contact us at with your report and we’ll help.

@Sam_Parry The hardware test crash is fixed in the newest version of the firmware which you can install with the firmware restore. If the restore fails, please contact us at the email above with your error report. Send the report after the restore fails so it gets logged.

The issue with the motors seems like a hardware issue to me however. Otherwise the problem would be apparent on all Wheelsons. Contact us at the support email mentioned and we’ll get to the bottom of it.



Hi Filip,

I’ve upgraded to the 1.61 version, but I can not figure out how to get to or send an error report. If it’s supposed to be an option when the error comes up, it does not appear, and I don’t see anything new in the menus. Please advise, thanks.



After the error happens, it will get logged internally. You can then close the error message, scroll to the bottom, and in the footer you will see a “Send error report” button. Clicking it will open a window showing all the information which will be sent, which includes the error that happened as well as some other info about your system that might help us resolve your problem. When you click “Send report”, the report will be sent to tour servers, and you will get a report ID. Please send us an email at with your problem and the report ID and I’ll be able to assist further.


1 Like

Same or similar problem here: Installing CircuitBlocks (1.6.2) on macOS 12.0.1 (m1) in order to interact with Spencer

The installer asks for some authorization/permission

arduino installer wants to make changes

not sure what kind of changes it needs to make, but in the end (after allowing), the installed arduino won’t run:

The application “Arduino” can’t be opened

In the end I can’t do much - can’t compile or run code, install/restore firmware. It’s somewhat of a disappointing experience.

Compile error. Check your code then try again.

(even if I install Arduino by itself in a way that it will start up)

I might try linux later, but I would have assumed macOS to be well supported.

I sent an error report, id 841

Unfortunately no reply/response after a week. For me (and the general audience of the product) spencer is a useless gadget if I can’t write/upload code for it and experiment with it.

For now I’ll just review it as “does not work too well with macos” in the shop where I bought it and move on.

Can you please send me a direct message with the email address you’ve used to report the issue?

I will help you make your Spencer work

I wasn’t aware I had to send an explicit email alongside the report (id 841). I will do so now with a copy/paste of my posting above.

Yes, please send an email via and include your error report ID.

We cannot contact you just based on your error report since the data inside is anonymized. In other words, we can see that something is wrong from the error report, but we don’t know which person is having that issue or how to reach out to the person.

So I did properly contact support by email this time (about 2 weeks ago now), referenced my error report id. I got a response an engineer would look at it and then… nothing.

Both support and community seem non-functional

At this point I don’t really care to bother anymore. I’m just disappointed about the whole experience. I like the idea but the execution just seems really poor.

Ivo, thank you for your message.

We were extremely busy fulfilling the latest stem box. We need a bit more time to solve your issue.

As stated in our response, we will get back to you as soon as possible.

I will personally overwatch your ticket so that it’s resolved in a timely manner.

Thank you for supporting our work

@albertgajsak any updates on this?

1 Like

Hi @oscar,

thank you for reaching out.

Please send us an email at explaining the issues that happen on your device so we can help out immediately.

Thank you in advance,