Update firmware on bit not working

I have recently bought myself a circuitmess bit and some other wacky robots. When I plugged in a wacky robot, the bit said to update my firmware. I went to the page, installed the circuitblocks agent, and… it didn’t detect that I have the agent installed nor gave me the permission to update the firmware. I downloaded the agent through the link you have to the download on the “restore firmware” page of circuitblocks. It also says I have to launch some circuitblocksagent.app app which, i don’t have after the installation, I tried to repair the install, I deleted the installer and installed a new one, and etc. It still doesn’t detect that I have it, although I downloaded it already.

Can you help out?

1 Like

I have found out the issue, it was that I was using an unsupported browser called “brave”. I tried it on google and everything works, so no worries!

1 Like

Hey @Gabi_Kraljic,

glad to hear you managed to resolve the issue.

Thank you for your support!