Upload to makerbuino not working

Hi all.

I don’t know what am I doing wrong but upload is not working.
UART board driver is installed, COM port is active in Arduino IDE but when I try to upload an example from Gamebuino library nothing is happening on my Makerbuino. Also on UART board Tx and Rx LEDs are not working.
i even did a loopback test on UART board an it worked.

If you do the loopback test (without the MAKERbuino), do the LEDs flash? Have you connected the right way around? It should be connected like this, if you’re not using the extension cables:

Also, the MAKERbuino needs to be turned on, because the UART board cannot power the console.

Yes, LEDs flash during loopback test but not during upload.
I have tried to connect the card both ways and Makerbuino is always on.

Hmmm… Sounds like something is shorting. Can you measure VCC on the FTDI board when plugged in? The LEDs are directly driven by the FTDI chip, so I suspect that VCC collapses when you plug it in. Could you check that?

thank you for supportign MAKERbuino and welcome to the forum! :slight_smile:

Please give us photos of your board with the UART board connected. We cannot help you without seeing your build.

Also, did you select Arduino UNO as your desired board and are you sure that you’ve selected the right COM port?