Maker buino built lights up but nothing on screen, any ideas?


Pretty much completed my build now! :slight_smile: issue is screen lights up but apart from small bar at the top of the screen nothing displays as seen in pictures.
Any ideas? User error or defective screen?
Cheers

Have you tried the hard reset?.. With the Makerbuino turned off, hold the C button down and turn on the Makerbuino, after 2-3secs release the C button and wait 20-30 secs…

@bitfogav, I have the same problem! I tried everything! I can’t get any answer that would solve this and Albert isn’t replying (tried contacting him several times). Can you please tell me if you know what the problem is? I tried resetting but didn’t change anything!
I just have a light on the screen, the brightness doesn’t change!
Please see the pic below. I’m getting frustrated it’s been months I can’t play nor code :(:disappointed_relieved:


Help please…

Can you upload some close-up pictures of both sides of the board with the screen removed so we can see the components, please?

1 Like


Hello @Dalemaunder here are close up pics, if you need better ones please let me know. Thank you for your help!

Hi! After several successful launches of games, there was the same problem. A full reset did not help (C button + power on 3 sec).

I had the same problem…
Lights in the screen will light up because they are just a secondary circuit with some LEDs, not really part of any screen logic as such…
For me the problem turned out to be a bent and thus badly soldered pin on the ATMega socket (I had to completely desolder it, fix the pin and resolder).
My suggestion would be that you make absolutely sure you placed and oriented everything correctly (check, double and triple check) and that your solder joints are all ok.

1 Like

Looks like there is a bridge between the first two pins of the screen socket!

1 Like

@Alex_Collins, what is the status of your problem? Any progress? Please send us some more photos of your MAKERbuino’s front and back side. Also, include a photo of your MAKERbuino’s front with the screen detached so that we can check the soldering joints on the microcontroller’s socket.
We really can’t help you without this.

@ABS, please send us photos of your MAKERbuino’s front and back side and include some more info so that we can help you more easily.

@bitfogav, @Dalemaunder, @tommyph1208, @synd, thank you for helping out on this thread!

Hi @albertgajsak,

My son’s maker was working originally, although it did freeze frequently which was resolved with a hard-reset. He quickly lost interest because of the constant need to reset, but has now re-gained interest however it won’t show anything on screen and the hard-reset doesn’t work anymore.

It is fully charged.

Any thoughts?

Thanks,

Nick

Oh crikey, is this forum even monitored any more? @albertgajsak

It’s very unusual for a microcontroller to freeze so you need to do a hard-reset. Have you checked all solder joints? It could be a bad connection.

1 Like

It was working fine (other than needing frequent resets), now nothing. Hasn’t been changed. Kept it the original box.

As I said the need to do a hard-reset is very unusual unless it’s a bug within the code. Can you post some pictures of the MAKERbuino? Maybe there is a bad solder joint causing the problem or a short circuit which damaged something.

1 Like

Hi everybody!

I had the same problem and I knew it was not the soldering, so I tried to burn the makerbuino/gamebuino bootloader on the chip with an ordinary Arduino as a programmer and it worked for me.
Maybe you can fix it like this too. Good luck!

1 Like

Afraid I don’t have arduino

@magnetto, thank you for sharing this and congrats on burning the bootloader. If you ever come to Croatia, I’m buying you a beer! :beers:

We’re in the process of solving @Steve’s problem in another topic.

@NickA, this forum is monitored and will be monitored in the future. Unfortunately, there were too many things happening lately and the market’s demand high and I didn’t manage to answer to every community forum topic in time. If something is urgent, please contact us via email as that is our primary contact channel and is monitored daily.

About your problem - the freezing problem is something that I did not yet see on a microcontroller. As @Bl4ckM4ch1n3 stated, you are most likely experiencing a problem caused by turning the console off while loading a game (it says “do not turn off” when something is loading for a reason). That can be fixed with a hard reset using button C. If the hard reset is not working, you are most likely going to need to reinsert the card a couple of times and blow in the SD socket really hard to clean the dust particles (works in the most cases).
If that doesn’t help, please give us some photos of your build’s front and back without the casing.

Hi Albert,

We have it working again by using the hard reset. It works for a while before hanging again. A further hard reset and we’re back going. Any suggestions what could be causing this? I’ve checked all of the solder joints for possible shorting, but they are all fine as far as I can tell.

Thanks,

Hi @NickA,
When is it hanging again? Is it haning when you’re trying to flash the loader again (pressing the C-button while the title screen is showing)?

same thing not working