Not flashing from SD card

I’ve built the Makerbuino. The initial tests checked out OK, and when soldering was complete the system starts up and performs setup tasks. The buttons all work etc. The step to flash from SD card is not working. Pressing C in the step to flash from SD is failing… Instead of doing something for 30s or so it shows ‘Flashing’ then reverts to the previous screen. This is the same behaviour as if I try with no SD card plugged in, so I guess that the problem is that the SD slot is not correctly soldered.

I’ve tested with a multimeter for continuity, but struggled to match the pin numbers from the circuit diagram with those on the SD card slot. The pin numbers from the ATMEGA are clear enough as theyre labelled on the PCB.
Counting pins up from the SD card notch to the tiny 3 unused pins gives 8 pins. I’ve called pin 8 the one closes to those 3 unused ones.

ATMEGA pins 16 is shows connected to SD 5 and 4; pin 17 to 5; pin 18 to 5 and 7; pin 19 to 5.

This suggests that I’ve managed somehow to make a mess of the soldering for the SD card.

What can you advise? Desolder the SD card slot and clean it up? Can you advise on how to identify the pin numbers on the SD card slot as that would help with testing for continuity correctly?

@William_Whittle, thank you for supporting MAKERbuino.

I think that you’re overthinking this as it sounds like a simple contact issue.

Please try and to this

  1. remove the SD card from the SD socket
  2. blow into the SD socket real hard to clean the dust and any unwanted particles
  3. insert the SD card into the SD socket
  4. repeat steps 1 - 3 a couple of times
  5. insert the SD card in the socket
  6. try doing hard reset like this:
  • turn the console OFF
  • hold the C button
  • turn the console ON
  • release the C button
  • wait for 30 seconds
  1. if nothing happens, please send me a couple of photos of your MAKERbuino’s front and back side with the casing and the screen removed.

Thank you for your patience.
Don’t give up!

Albert from the MAKERbuino team

Thanks for your very quick reply!

I’ve tried as you suggest, but it’s still the same.

Here’s the back. To get a photo of the front with no screen will take more time as I’ll need to desolder the screen connectors.

Sorry, don’t remove the screen yet, just send me a photo of the front side

Also, your soldering joints seem to lack some more heat.

Take your soldering iron and reheat the soldering joints on the SD card socket once more and try again.

Here’s the picture of the screen side.

I tried as you said to reheat those joints again, but it’s behaving exactly the same.

@William_Whittle, can you please send us a photo of your revised soldering work?

If the SD socket’s soldering joints are not causing the problem, you most likely need to reheat the joints on your microcontroller’s socket (underneath the screen).

Removing the screen can be tricky and I’d suggest you send us the MAKERbuino so that we can repair it if you do not manage to make it work.

Thank you for your patience and understanding.

Hey there,
I had exactly the same problem. I `ve checked all solderings, removed display again, resoldered chip socket.
Prolbem was the same.
Then I tried it with an other MicroSD to SD Adapter - it works!

So give it a try, use an other card adapter.

Best regards,

1 Like

@Dan, thank you for your advice here.
This is quite strange as we test every single SD card and SD adapter before shipping them to customers.
I am sorry that you had to deal with a defective SD adapter, shall we send you a new one?

@William_Whittle, any news here? Did you mange to make your MAKERbuino work in the meantime?

@albertgajsak, theres no need to send me a new adapter, I have enough. Strange thing is your adapter is working with my Mac, but not with Makerbuino - so its not completly defect.

Ok, I appreciate your understanding. Yes, that’s quite strange…

@albertgajsak the same thing has been happening to me, where the sd card and adapter both work on my computer but not on the makerbuino

@Brady, thank you for supporting makerbuino and I am sorry for the problems that you’re experiencing.

This sounds like a connection problem possibly caused by bad soldering joints.

Please, create a new topic for your issue and give us some photos of your device’s front and back side.


I noticed that micro Sd is so hard to push out adapter may that means adapter is not good?

@Leo, thank you for supporting MAKERbuino!

I am sorry, but I cannot tell you whether your adapter is good or not based on that description.

We do test all of the adapters with micro cards in them before sending them to the customers.

Can you please open a separate topic in the support section and give us a few photos as well as a more detailed description of your problem?

thanks and don’t worry, we’ll help you fix your MAKERbuino :slight_smile:

I jist relised that i didnt soldered one pin for sd card socket and it works good now

Neat! :slight_smile:
I’m glad that it works now.

If you need anything, feel free to contact me here!

But the way what power supply do i need to use to charge my makerbuino how many A and V?

@Leo, check the answer here: