SMS not received

I can send but i cant receive any kind of sms .
I have the 1,0,5 firmware.

Is there any problem with receiving sms with the current version ?

Thank you

When cellular signal is strong, you should have no problem either direction, but if signal is not the best, this is a different story (AKA “Another long story from TheWebMachine”)…

You’re still on the SIM800 module, yes? I know on the SIM7600, if the signal is weak, you’ll have issues with SMS because the message will keep coming in fragmented and Ringo doesn’t handle this well AT ALL. I think the issue here is that the Ringo firmware is currently coded to read incoming (and send outgoing) SMS in realtime using manual commands and store it in a local Ringo DB. However, I discovered there is a better way of handling this…

In reality, the SIM modules - at least the SIM7600 series; not sure about SIM800 - have built-in Inbox/Outbox/etc support and that would be more reliable - offload the bulk of SMS work to the SIM module, which sits idle most of the time, anyway, and is tailored for the work - than forcing all of the work of reading and sending SMS in realtime from the SIM module by the firmware itself. Cellular is flaky and the Ringo firmware just isn’t written as robustly as the built-in SMS handling of the SIM module.

I forked the Ringo firmware a little while back so that I could take a deep dive into this (among other things, like enabling Cellular Data access for apps instead of relying on WiFi alone). I would like to re-code the SMS handling to let the SIM module do the sending/receiving/storing of SMS entirely on its own with minimal need to call upon Ringo. In this case, SIM would notify Ringo that a new message was waiting and Ringo would poll the SIM module’s inbox/outbox/etc directly, instead of trying desperately to capture and reassemble message data in realtime. When sending a message, Ringo would throw the message at the SIM module in queue mode and let the SIM module send it and notify Ringo when it is sent successfully, instead of manually sending/receiving the commands and endlessly waiting for response from a potentially bad cell signal (without any sort of automatic retry, mind you).

Nothing from the user’s perspective would change, spare quicker responsiveness from Ringo with SMS, since it can handle other tasks while waiting on SIM to do the SMS work…this would just be a re-write of the SMS backend. I hit a decent stopping point in my WiFiTest app, so I really should set that aside and pick this matter up again.

Honestly, I don’t know that we’ll see another official major firmware revision for Ringo anytime soon. The small team at CircuitMess have moved on, development resource-wise, from Ringo and on to the bunch of other STEM projects they have been launching recently. This is something the Community has to take on…and I think I’m up for the challenge. If we fix these types of issues and submit proper pull requests via github to the CircuitMess team, I bet they’d consider merging it into a new official firmware version.


1 Like

Thank you for your very detailed answer.

I have the sim800 module. I have no problem with the signal. Its very strong. My problem is that i can send SMS but i cannot receive . I am sending adding the country code in front of the number. I have tried from two phones to send SMS to RINGO adding the country code in frond of the number and without adding the country number but without result. No SMS received.

Well, receiving shouldn’t be affected by the number format from the sending device…if you use the same format on the sending device as you would texting any other number from the sending device, it should work.

Try this:

  1. On Ringo, Setting > About & Update > SIM Module Debug
  2. Fire up Serial Monitor in Arduino so you can see output (and interact with modem) and plug the Ringo in
  3. Send an SMS to Ringo # and see if you see the SIM module pick this up in the serial monitor.

If you see the SMS activity come in on monitor, then it’s likely a Ringo firmware issue, if you don’t see it on the Serial Monitor, then this is a network and/or signal issue. The last link in my References above goes in depth on sending/interpreting the AT commands on the Serial Monitor in this debug mode.


I am at the Sim Module Debug menu

I have fired up the serial monitor and i have choose the RINGO board
i have tried some commands but i dont see any respond from sim module.

Maybe i have made something wrong.

Did you try any of the commands we discuss in this thread:

The modem commands start with AT and commands are CaSe SeNsItIvE. Here’s the complete AT command manual for the SIM800:

And, if you swap out for the SIM7600 (or someone else comes by this thread), that AT command manual can be found here…it’s mostly identical, tho:

Hey there!

Is your SD card in?
Since the messages are stored directly there, if the card is not in you’ll not be able to receive them?

Also, if the SD card is somewhat corrupted, there could also be some problems.

Try reformatting and getting the original files back to it -



Of course the SD card is inside and it is not corrupted.

I have formatted it again and i got all the original files back to it. I am trying to debug the problem with the serial monitor as the WebMachine told me.

Thank you for your answer

You can try switching to some older firmware version just to make sure it’s not a hardware issue, even though we didn’t really change the mechanism, something could’ve just fallen apart.

You can do that in the Arduino IDE - here is a tutorial on how to install Ringo package for Arduino IDE -

Then when downloading the board manager, just download one of the older versions and then Burn bootloader to get an older version of the firmware. :slight_smile:

Stay in touch,