No text displayed step 12 fail [SOLVED]

Hi, my girlfriend bought me a Makerbuino for my birthday some time ago and I’ve finally got around to putting it together.

I got up to step twelve but powering it on did absolutely nothing. Nothing on the display :frowning:

Here’s the photos of the build

Any help much appreciated. My heart really sank when it didnt do anything. I checked the transistor & regulator locations and even tried charging the battery, but the switch had no effect :frowning:

The soldering looks okay from what I can see. You could resolder the transistor and the voltage regulator as the pads arent fully covered. Reheating should do the trick.

How did you try to charge the battery without the charging board?

Thanks, I’ll give that a go. :slight_smile:
I have an imax b6ac charger so I alligator clippee that to a couple of offcut component legs and inserted them into the battery jst connector :D.

Hopefully resoldering the transistor and vreg will solve it. I had some trouble with a couple of the pads just not getting hot enough to flood properly. Not sure why, I tried cleaning the iron and putting a dab of fresh solder on it. Maybe more time to heat the pad? Or change angle for better contact?

No joy, I resoldered the reg and transistor and still no life to my Makerbuino :(. Any other suggestions!

Hey @gazzat5, thank you for supporting the project and I’m really sorry for the problems that you’re experiencing.

hmm… the last think I’d check on your place is the battery - please solder the blue charging board and try charging the battery.

If this doesn’t help, can you please send it to us in a letter:
Maksimilijana Vrhovca 11,
47000 Karlovac,

You only need to send us the circuit board.

I’ll personally take a look at your console, fix it and get returned to your address ASAP.


  • Albert

Hi, Sorry for a late reply but can I recommend you try Step 13 and solder the R3 10k resistor and retest…

Guys I’ve no idea what happened, I plugged it back in to try and run another test and it’s working!

I was going to try this Testing Point - Won't turn on but now I’m going to get back to the soldering :). Hopefully it will stay working!

1 Like